Ubuntu’da `Requires installation of untrusted packages´ sorunu

Bir kaç gündür Ubuntuma bir şeyler yüklemek istiyordum fakat hatayla karşılaşıyordum. Update Manager kullandığımda ise böyle bir hata çıktı.

Requires installation of untrusted packages @ubuntu

Requires installation of untrusted packages @ubuntu

Öncelikle Update Manager’ın download yaptığı serverı United States yerine Main Server yapıp denedim, ama çözüm olmadı.

Daha sonra terminalde NO_PUBKEY şeklinde bir hata olduğunu farkettim. Onun da resmi şöyle;

terminal @ubuntu

terminal @ubuntu

Resimde de altını çizdiğim olaymış derdimiz meğer 🙂

Yapmamız gereken şu, öncelikle terminali açıp update ediyoruz.

sudo apt-get update

Çıkan PUBKEY’leri bir kenarda tutalım, çünkü birazdan işimize yarayacaklar. Bende 1 tane vardı, sizde birden fazla varsa ayrı ayrı işlem yapabilirsiniz.

sudo apt-key adv --recv-key --keyserver keyserver.ubuntu.com XXXXXXXXX

XXXXXX yazdığım yere PUBKEY gelecek, yani ben B725097B3ACC3965 yazdım.

Daha sonra tekrar update;
sudo apt-get update

Artık rahat rahat download yapabilirsiniz!